Samba4 AD DC Domain Provision Problem

Samba4 AD DC Domain Provision Problem

Beitragvon Felix941 » 17.11.2016 13:58

Hey Forum,
das ist mein erster Post ich hoffe ich bin in der Richtigen section Bild

Ich habe mit OpenSuSe 42.1 probiert einen Samba4 AD DC Server zu erstellen.
Ich komme soweit bis ich die "Domain Provision" machen muss. Wenn ich probiere $ samba-tool domain provision auszuführen bekommen ich folgenden fehler:
______________________________________________________________________________________________________________
Code: Alles auswählen
 samba-tool domain provision
 Realm: CAT.NET
 Domain [CAT]: CAT
 Server Role (dc, member, standalone) [dc]:
 DNS backend (SAMBA_INTERNAL, BIND9_FLATFILE, BIND9_DLZ, NONE) [SAMBA_INTERNAL]:
 DNS forwarder IP address (write 'none' to disable forwarding) [192.168.1.1]:
 Administrator password:
 Retype password:
 Looking up IPv4 addresses
 Looking up IPv6 addresses
 No IPv6 address will be assigned
 Setting up secrets.ldb
 Setting up the registry
 Setting up the privileges database
 Setting up idmap db
 Setting up SAM db
 Setting up sam.ldb partitions and settings
 Setting up sam.ldb rootDSE
 Pre-loading the Samba 4 and AD schema
 Adding DomainDN: DC=cat,DC=net
 Adding configuration container
 Setting up sam.ldb schema
 Setting up sam.ldb configuration data
 Setting up display specifiers
 Modifying display specifiers
 Adding users container
 Modifying users container
 Adding computers container
 Modifying computers container
 Setting up sam.ldb data
 Setting up well known security principals
 Setting up sam.ldb users and groups
 Setting up self join
 ldb: module partition initialization failed : Operations error
 ldb: module show_deleted initialization failed : Operations error
 ldb: module dns_notify initialization failed : Operations error
 ldb: module extended_dn_out_ldb initialization failed : Operations error
 ldb: module linked_attributes initialization failed : Operations error
 ldb: module operational initialization failed : Operations error
 ldb: module repl_meta_data initialization failed : Operations error
 ldb: module subtree_delete initialization failed : Operations error
 ldb: module aclread initialization failed : Operations error
 ldb: module acl initialization failed : Operations error
 ldb: module descriptor initialization failed : Operations error
 ldb: module objectclass initialization failed : Operations error
 ldb: module asq initialization failed : Operations error
 ldb: module server_sort initialization failed : Operations error
 ldb: module vlv initialization failed : Operations error
 ldb: module paged_results initialization failed : Operations error
 ldb: module dirsync initialization failed : Operations error
 ldb: module schema_load initialization failed : Operations error
 ldb: module dsdb_notification initialization failed : Operations error
 ldb: module rootdse initialization failed : Operations error
 ldb: module samba_dsdb initialization failed : Operations error
 ldb: Unable to load modules for /var/lib/samba/private//sam.ldb: partition_metadata: Migrating partition metadata: create of metadata.tdb gave: partition_metadata: Unable to create /var/lib/samba/private//sam.ldb.d/metadata.tdb: Device or resource busy
 samdb_connect failed
 VFS connect failed!
 ERROR(runtime): uncaught exception - (-1073741823, 'Undetermined error')
 File "/lib64/python2.7/site-packages/samba/netcmd/__init__.py", line 176, in _run
 return self.run(*args, **kwargs)
 File "/lib64/python2.7/site-packages/samba/netcmd/domain.py", line 461, in run
 nosync=ldap_backend_nosync, ldap_dryrun_mode=ldap_dryrun_mode)
 File "/lib64/python2.7/site-packages/samba/provision/__init__.py", line 2175, in provision
 skip_sysvolacl=skip_sysvolacl)
 File "/lib64/python2.7/site-packages/samba/provision/__init__.py", line 1806, in provision_fill
 names.domaindn, lp, use_ntvfs)
 File "/lib64/python2.7/site-packages/samba/provision/__init__.py", line 1539, in setsysvolacl
 smbd.set_simple_acl(file.name, 0755, gid)

_________________________________________________________________________________________________________

So und da ich nichts zu diesem Fehler gefunden habe dachte ich ich frag hier mal.

Mit freundlichen Grüßen
Felix
Zuletzt geändert von tomfa am 17.11.2016 18:46, insgesamt 1-mal geändert.
Grund: Code-Tags gesetzt.
Felix941
 
Beiträge: 1
Registriert: 17.11.2016 13:39



Zurück zu openSUSE

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast